Google Email Integration Disruption

Incident Report for GlassHive

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 20:45 UTC

Investigating

We are currently experiencing issues with our integration with Google, affecting the ability to receive email responses and send emails through Google. Our team is actively investigating the issue, and we will provide updates as soon as possible.
Posted Mar 06, 2025 - 16:04 UTC
This incident affected: Integrations.