Click tracking is down for marketing email campaigns and 1-to-1 emails through Microsoft 365
Incident Report for GlassHive
Resolved
This incident has been resolved.
Posted Oct 29, 2024 - 13:52 UTC
Update
We have isolated and resolved the issue with click tracking. We'll be monitoring this service throughout the day.
Posted Oct 29, 2024 - 13:52 UTC
Investigating
We are currently investigating this issue.
Posted Oct 29, 2024 - 13:26 UTC
This incident affected: Platform.